Access Denied

Jun 17, 2009 at 7:48 PM

Using the command line:

C:\Users\Chris\Downloads\OpenXMLViewer>OpenXMLViewer in.docx C:\Users\Chris\Downloads\OpenXMLViewer FIREFOX

Ends execution with:

Microsoft OpenXML Document Viewer

For more help, Please visit at  http://www.codeplex.com/OpenXMLViewer/

Access Denied

Any ideas why?

Version: Windows CMD Apr 26
Operating System: Windows Vista Home Premium

 

Coordinator
Jun 22, 2009 at 10:09 AM

Hi,

Could you kindly verify the same issue by copying the OpenXMLViewer folder contents to another location (say c:\openxmlviewer) along with the files? This issue may be due to a file write permission restriction in the User\Chris\Downloads folder.

Regards,

Anand

Jun 22, 2009 at 4:26 PM

Hey Anand,

Good to hear from you again.

I thought the problem might involve a permission error, so (prior to the previous post): I copied the OpenXMLViewer contents to the C:\ folder and to the C:\User\Chris\Documents. I should have mentioned this in the first post, however none of the locations produced different results.

Any other ideas?

Thanks for all the help,

Chris

 

Coordinator
Jun 29, 2009 at 10:48 AM

Hi Chris,

Could you try this again with the word document on another folder? Also could you try running as another user with higher permissions (Run as..) and post the results here?

Best regards,

Anand

Jun 29, 2009 at 3:35 PM

Anand,

Moving the word documents to different folders produced the same "Access Denied" result.

However, going to Windows\System32 and right clicking "Run as adminstrator" fixes the problem... is there any way to get this to work without having to go through the UAC dialog every time... i.e. running it as a standard user?

Thanks,

Chris

Coordinator
Jul 1, 2009 at 10:15 AM

Chris,

 Can you provide me with some more detail regarding where OpenXMLViewer.exe was present?

Regards,

Anand

Aug 12, 2009 at 9:54 PM

I've put OpenXMLViewer.exe in the C:\ drive, in C:\Users\Chris\Documents, in C:\Users\Chris\Downloads etc etc.

No matter where I put the exe file, it fails. I've also tried setting the destination directory to the C:\ drive, in C:\Users\Chris\Documents, in C:\Users\Chris\Downloads etc etc.

And by fails I mean that the xhtml file generates, but nothing is written to the word/media folder itself. The directory is blank and an access deined error appears in the command prompt. I'm almost certain that this means that the program fails when writing the images from the DOCX file to disk.

Any more ideas? I'm just lost on this one.

Coordinator
Aug 31, 2009 at 11:38 PM

Hi Chris,

 I believe that the above problem is due to insufficient rights for the logged in user. Could you try giving %TEMP% folder write access for the user and try the same? The error typically is due to insufficient rights allotted for the user.

Do let me know how this turns out.

Regards

Anand

Sep 1, 2009 at 2:34 PM

Hey Anand,

Good to hear from you.

I gave full control to both C:\Windows\Temp and the local temp (C:\Users\Chris\AppData\Local\Temp\)... still no luck.

Thanks, Chris

Sep 11, 2009 at 7:41 AM

Welcom.

 

I have exactly the same problem.

I use converter in ASP.NET application, so i have to gave correct permissions to iis user (network service) to run this application.

I already add %temp% full permissions, but it still not working. Image files are not safed in created subfolders, becouse of lack of permissions. If i run application as administrator, then it's no problem, they are created, but with normal user, it's problem.

Sep 11, 2009 at 8:30 AM

I see, that there is some problem with running xcopy from network user.

It's just not runned.