Linux: Unable to open docx files in firefox

Jun 16, 2010 at 5:57 PM
Edited Jun 16, 2010 at 6:07 PM
Linux: Unable to open docx files in firefox

Installed: OpenXMLViewer_linux_firefox.tar
OS: Linux From Scratch 6.6
Firefox: 3.0.1

(as su)
install.sh installed these files:
/usr/lib/mozilla/plugins/DocX2Html.xslt
/usr/local/lib/libTransformationCore.so
/usr/local/lib/libUtility.so
/usr/local/lib/libxalan-c.so
/usr/local/lib/libxalan-c.so.111
/usr/local/lib/libxalan-c.so.111.0
/usr/local/lib/libxalanMsg.so
/usr/local/lib/libxalanMsg.so.111
/usr/local/lib/libxalanMsg.so.111.0
/usr/local/lib/libxerces-c.so
/usr/local/lib/libxerces-c.so.28
/usr/local/lib/libxerces-c.so.28.0

(as user)
Dragging OpenXMLViewer_linux_firefox.xpi to firefox installed these files:
/home/jhalfs/.mozilla/firefox/41sy4e3i.firefox3/extensions/OpenXMLViewer@Codeplex.com/plugins/DocX2Html.xslt
/home/jhalfs/.mozilla/firefox/41sy4e3i.firefox3/extensions/OpenXMLViewer@Codeplex.com/plugins/License.txt
/home/jhalfs/.mozilla/firefox/41sy4e3i.firefox3/extensions/OpenXMLViewer@Codeplex.com/plugins/NPDOCX.so
/home/jhalfs/.mozilla/firefox/41sy4e3i.firefox3/extensions/OpenXMLViewer@Codeplex.com/plugins/readme.txt

Restarted firefox

In firefox, Tools->Add-ons->Extensions shows that OpenXMLViewer 1.0 is installed.

Attempting to open a docx file in firefox presents a pop-up which explains that
"You have chosen to open
DEEPWATER_HORIZON_SYNOPSIS_V2-0.docx
which is a: Binary File"

The only options are: Cancel / Save File